summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <[email protected]>2024-07-25 16:21:11 -0500
committerjgart <[email protected]>2024-07-25 16:23:05 -0500
commit1265e1e8eace30ab6f998d080f5892e79dc2ead6 (patch)
tree4bceab3f9c15f00db652b93521c26e353da371c3
parent03062c7a9fd74d625639e1a325e9cb58d1cd74e3 (diff)
gnu: Add bubger.
* gnu/packages/mail.scm (bubger): New variable. Change-Id: I68a3d4dea546b8643ddef19d2bd3dd5edd263cb4
-rw-r--r--gnu/packages/mail.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3dbc5bcb2a..d4f7924747 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -49,7 +49,7 @@
;;; Copyright © 2022 Thiago Jung Bauermann <[email protected]>
;;; Copyright © 2022 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2022 muradm <[email protected]>
-;;; Copyright © 2022 jgart <[email protected]>
+;;; Copyright © 2022, 2024 jgart <[email protected]>
;;; Copyright © 2022 ( <[email protected]>
;;; Copyright © 2022 Mathieu Laparie <[email protected]>
;;; Copyright © 2023 Timo Wilken <[email protected]>
@@ -85,6 +85,7 @@
#:use-module (gnu packages c)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
+ #:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
@@ -4340,6 +4341,37 @@ related tools to process winmail.dat files.")
Git and exports them in maildir format or to an MDA through a pipe.")
(license license:gpl2))))
+(define-public bubger
+ (package
+ (name "bubger")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://git.causal.agency/bubger/snapshot/bubger-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "014r9p7f0ismhybvcs4p3s4ph3lcygn15kfdkd73i09fb82pqyw6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; There are no tests.
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))))
+ (native-inputs
+ (list pkg-config universal-ctags))
+ (inputs (list libressl))
+ (home-page "https://code.causal.agency/june/bubger")
+ (synopsis "IMAP archive generator")
+ (description
+ "@command{bubger} is a mailing list archive generator for mail stored in
+IMAP. It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access. It requires the IMAP THREAD
+extension.")
+ (license license:gpl3+)))
+
(define-public public-inbox
(package
(name "public-inbox")