summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-01 09:31:02 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 21:01:39 +0000
commit0df28169f34ab6b82df88c5e3a633ce30320a0fd (patch)
tree30743b0d7b68967ff468c6bb66dd643e0a0f843a
parent08dd8e45062a2b3b5ad34fc92c8c8b10bacbffd9 (diff)
gnu: python-flake8-implicit-str-concat: Update to 0.5.0.
* gnu/packages/python-xyz.scm (python-flake8-implicit-str-concat): Update to 0.5.0. [build-system]: Swap to pyproject-build-system. [arguments]<tests?>: Explicitly disable them as no provided in PyPI archive or Git checkout. <phases>: Remove 'loosen-requirements. [native-inputs]: Add python-hatchling. Change-Id: If3fc55d3505a835bd9222b19dd03a755a8aa5e9e
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f193be0a50..a69f671de1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15412,24 +15412,22 @@ and @code{InteractiveShellEmbed()()}.")
(define-public python-flake8-implicit-str-concat
(package
(name "python-flake8-implicit-str-concat")
- (version "0.2.0")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "flake8_implicit_str_concat" version))
(sha256
- (base32 "1v0y29xlmbr2q12a4nnpm1dm9aw1mjiys1x8jif4z8c90d63cqm6"))))
- (build-system python-build-system)
+ (base32 "1s59w4x053j4794n6h9c7hafa8jjjymx6aar5q23pjw4vrdis7hh"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:tests? #f ;no tests
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'loosen-requirements
- (lambda _
- ;; Permit newer versions of attrs. Remove for >0.2.
- (substitute* "setup.py"
- ((", <21") "")))))))
+ (list
+ #:tests? #f)) ; no tests in PiPY or git checkout
+ (native-inputs
+ (list python-hatchling))
(propagated-inputs
- (list python-attrs python-more-itertools))
+ (list python-attrs
+ python-more-itertools))
(home-page "https://github.com/keisheiled/flake8-implicit-str-concat")
(synopsis "Flake8 plugin to encourage correct string literal concatenation")
(description