summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2025-03-03 12:48:16 +0800
committer宋文武 <[email protected]>2025-03-03 12:48:16 +0800
commit06497493436830d303bb505474f31d01737c4c7b (patch)
tree9a1b39427ad9537b25ce2c74ed62494417727b2e
parent7e7ad582e47111b1524edd48372e51ad1294d683 (diff)
gnu: xournalpp: Fix build.
Reported in <https://issues.guix.gnu.org/76697>. This is follow up to 4838b7b0e94c7636cc2639e3b53d3fe37251fca2. * gnu/packages/pdf.scm (xournalpp) [arguments]: Add generate-gdk-pixbuf-loaders-cache-file phase. Change-Id: Ia29fb52f5f8852292fc35952d89a8769daacfae6
-rw-r--r--gnu/packages/pdf.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index ce63306c07..23348e49d5 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1090,6 +1090,9 @@ using a stylus.")
(invoke "cmake" "--build" "." "--target" "test-units")))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
+ (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'generate-gdk-pixbuf-loaders-cache-file))
(add-after 'glib-or-gtk-wrap 'wrap-gdk-pixbuf
;; This phase is necessary for xournalpp to load SVG icons.
(lambda _