summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm43
1 files changed, 13 insertions, 30 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c2f5b52042..5375424ce6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -50,7 +50,7 @@
;;; Copyright © 2021 Alexey Abramov <[email protected]>
;;; Copyright © 2021, 2022, 2023 Andrew Tropin <[email protected]>
;;; Copyright © 2021 David Wilson <[email protected]>
-;;; Copyright © 2021,2022 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <[email protected]>
;;; Copyright © 2020 Hartmut Goebel <[email protected]>
;;; Copyright © 2021 Raghav Gururajan <[email protected]>
;;; Copyright © 2021 Thiago Jung Bauermann <[email protected]>
@@ -741,36 +741,19 @@ stream decoding")
(base32
"1vkh19gb76agvh4h87ysbrgy82hrw88lnsvhynjf4vng629dmpgv"))))
(build-system gnu-build-system)
- (native-inputs
- `(("config" ,config)
- ("makeinfo" ,texinfo)))
- (inputs
- (list ncurses))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'update-config-scripts
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- ;; Replace outdated config.guess and config.sub.
- (for-each (lambda (file)
- (install-file
- (search-input-file
- (or native-inputs inputs)
- (string-append "/bin/" file)) "."))
- '("config.guess" "config.sub"))))
- (replace 'configure
- (lambda* (#:key build inputs outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out"))
- (ncurses (assoc-ref inputs "ncurses")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (invoke "./configure"
- "--disable-static"
- (string-append "--prefix=" out)
- (string-append "--build=" build)
- (string-append "--with-ncurses="
- ncurses))))))))
+ (list
+ #:configure-flags
+ #~(list "--disable-static"
+ (string-append "--with-ncurses="
+ #$(this-package-input "ncurses")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'force-autoreconf
+ (lambda _
+ (delete-file "configure"))))))
+ (native-inputs (list autoconf automake libtool texinfo))
+ (inputs (list ncurses))
(home-page "https://aa-project.sourceforge.net/aalib/")
(synopsis "ASCII-art library")
(description