summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/prolog.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/prolog.scm b/gnu/packages/prolog.scm
index 99e7e26193..4044c2d529 100644
--- a/gnu/packages/prolog.scm
+++ b/gnu/packages/prolog.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 Nikita Karetnikov <[email protected]>
;;; Copyright © 2013 Mark H Weaver <[email protected]>
;;; Copyright © 2020 Brett Gilio <[email protected]>
-;;; Copyright © 2021 Efraim Flashner <[email protected]>
+;;; Copyright © 2021, 2024 Efraim Flashner <[email protected]>
;;; Copyright © 2021 Maxime Devos <[email protected]>
;;; Copyright © 2024 jgart <[email protected]>
;;;
@@ -193,12 +193,19 @@ it.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- (list git valgrind xxd))
+ (append
+ (if (supported-package? valgrind)
+ (list valgrind)
+ '())
+ (list xxd)))
(inputs
(list libffi openssl readline))
(arguments
(list
#:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+ #:test-target (if (this-package-native-input "valgrind")
+ "check"
+ "test")
#:phases
#~(modify-phases %standard-phases
;; Upstream does not use a configure script.