summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-build.scm51
-rw-r--r--gnu/packages/golang.scm50
2 files changed, 51 insertions, 50 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index a8f4cbeb20..f66fe16bd0 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -11,11 +11,13 @@
;;; Copyright © 2021 Ludovic Courtès <[email protected]>
;;; Copyright © 2021 Sarah Morgensen <[email protected]>
;;; Copyright © 2021 hackeryarn <[email protected]>
+;;; Copyright © 2022 (unmatched-parenthesis <[email protected]>
;;; Copyright © 2023 Artyom V. Poptsov <[email protected]>
;;; Copyright © 2023 Felix Lechner <[email protected]>
;;; Copyright © 2023 Katherine Cox-Buday <[email protected]>
;;; Copyright © 2023 Nicolas Graves <[email protected]>
;;; Copyright © 2023 Timo Wilken <[email protected]>
+;;; Copyright © 2024 Hilton Chain <[email protected]>
;;; Copyright © 2024 Troy Figiel <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -765,6 +767,55 @@ Go programming language.")
1.13 error values.")
(license license:bsd-3))))
+(define-public go-google-golang-org-protobuf
+ (package
+ (name "go-google-golang-org-protobuf")
+ (version "1.31.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/protobuf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xf18kzz96hgfy1vlbnydrizzpxkqj2iamfdbj3dx5a1zz5mi8n0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "google.golang.org/protobuf"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? unpack-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" unpack-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; XXX Failing on i686-linux:
+ ;; panic: unaligned 64-bit atomic operation
+ (("TestDynamicTypesExtensionNotFound")
+ "OffTestDynamicTypesExtensionNotFound")
+ (("TestDynamicTypesFilesChangeAfterCreation")
+ "OffTestDynamicTypesFilesChangeAfterCreation")
+ (("TestDynamicTypesFindExtensionByNameOrNumber")
+ "OffTestDynamicTypesFindExtensionByNameOrNumber")))))
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (propagated-inputs (list go-github-com-google-go-cmp))
+ (home-page "https://google.golang.org/protobuf")
+ (synopsis "Go library for Protocol Buffers")
+ (description
+ "The protobuf package provides a Go implementation of Protocol Buffers, a
+language and platform neutral, extensible mechanism for serializing structured
+data. It is a successor to @code{go-github-com-golang-protobuf} with an
+improved and cleaner API.")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3e30cdf53f..4ca8c87cb2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6200,56 +6200,6 @@ data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license license:bsd-3)))
-(define-public go-google-golang-org-protobuf
- (package
- (name "go-google-golang-org-protobuf")
- (version "1.31.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/protobuf")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xf18kzz96hgfy1vlbnydrizzpxkqj2iamfdbj3dx5a1zz5mi8n0"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "google.golang.org/protobuf"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key tests? unpack-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" unpack-path)
- (substitute* (find-files "." "\\_test.go$")
- ;; XXX Failing on i686-linux:
- ;; panic: unaligned 64-bit atomic operation
- (("TestDynamicTypesExtensionNotFound")
- "OffTestDynamicTypesExtensionNotFound")
- (("TestDynamicTypesFilesChangeAfterCreation")
- "OffTestDynamicTypesFilesChangeAfterCreation")
- (("TestDynamicTypesFindExtensionByNameOrNumber")
- "OffTestDynamicTypesFindExtensionByNameOrNumber")))))
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
- (propagated-inputs (list go-github-com-google-go-cmp))
- (home-page "https://google.golang.org/protobuf")
- (synopsis "Go library for Protocol Buffers")
- (description
- "The protobuf package provides a Go implementation of Protocol Buffers, a
-language and platform neutral, extensible mechanism for serializing structured
-data.
-
-This package is a successor to @code{go-github-com-golang-protobuf} with an
-improved and cleaner API.")
- (license license:bsd-3)))
-
(define-public go-github-com-macronut-go-tproxy
(package
(name "go-github-com-macronut-go-tproxy")