summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/patches/libbraiding-no-s.patch9
-rw-r--r--gnu/packages/sagemath.scm7
3 files changed, 15 insertions, 4 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 117280fc11..eb2447ca6f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1,6 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012-2025 Ludovic Courtès <[email protected]>
-# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2022, 2023, 2024 Andreas Enge <[email protected]>
+# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2022, 2023, 2024, 2025 Andreas Enge <[email protected]>
# Copyright © 2016 Mathieu Lirzin <[email protected]>
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Mark H Weaver <[email protected]>
# Copyright © 2016 Chris Marusich <[email protected]>
@@ -1710,6 +1710,7 @@ dist_patch_DATA = \
%D%/packages/patches/libbase-fix-includes.patch \
%D%/packages/patches/libbase-use-own-logging.patch \
%D%/packages/patches/libbonobo-activation-test-race.patch \
+ %D%/packages/patches/libbraiding-no-s.patch \
%D%/packages/patches/libcaca-CVE-2021-3410-pt1.patch \
%D%/packages/patches/libcaca-CVE-2021-3410-pt2.patch \
%D%/packages/patches/libcanberra-sound-theme-freedesktop.patch \
diff --git a/gnu/packages/patches/libbraiding-no-s.patch b/gnu/packages/patches/libbraiding-no-s.patch
new file mode 100644
index 0000000000..3465004e62
--- /dev/null
+++ b/gnu/packages/patches/libbraiding-no-s.patch
@@ -0,0 +1,9 @@
+diff --git a/configure.ac b/configure.ac
+index 3867eb9..6572e1f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,4 +8,3 @@ AC_PROG_CXX
+ LT_INIT
+ AC_CONFIG_FILES([Makefile lib/Makefile libbraiding.pc])
+ AC_OUTPUT
+-s
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 30d226a1e8..28ebeeea1e 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -136,7 +136,7 @@ function for every found clique.")
(define-public libbraiding
(package
(name "libbraiding")
- (version "1.0")
+ (version "1.3.1")
(source
(origin
(method git-fetch)
@@ -147,10 +147,11 @@ function for every found clique.")
(file-name (git-file-name name version))
(sha256
(base32
- "0l68rikfr7k2l547gb3pp3g8cj5zzxwipm79xrb5r8ffj466ydxg"))))
+ "1d9vrn507phpzwwmmrxiig8s484rdi3gjghj75d4sdzbiqyyr9yp"))
+ (patches (search-patches "libbraiding-no-s.patch"))))
(build-system gnu-build-system)
(native-inputs
- (list autoconf automake libtool))
+ (list autoconf automake libtool pkg-config))
(synopsis "Computations with braid groups")
(description "libbraiding performs computations with braid groups,
in particular it computes normal forms of group elements.")