summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 26a059ddd4..95180ac316 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015 Eric Dvorsak <[email protected]>
;;; Copyright © 2016 Sou Bunnbu <[email protected]>
;;; Copyright © 2016 Jelle Licht <[email protected]>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <[email protected]>
+;;; Copyright © 2016-2023 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Rene Saavedra <[email protected]>
;;; Copyright © 2016 Ben Woodcroft <[email protected]>
;;; Copyright © 2016, 2023 Clément Lassieur <[email protected]>
@@ -1784,8 +1784,12 @@ UTS#46.")
(when tests?
;; The "Go Race Detector" is only supported on 64-bit
;; platforms, this variable disables it.
- (unless ,(target-64bit?)
- (setenv "ESBUILD_RACE" ""))
+ ;; TODO: Causes too many rebuilds, rewrite to limit to x86_64,
+ ;; aarch64 and ppc64le.
+ ,(if (target-riscv64?)
+ `(setenv "ESBUILD_RACE" "")
+ `(unless ,(target-64bit?)
+ (setenv "ESBUILD_RACE" "")))
(with-directory-excursion (string-append "src/" unpack-path)
(invoke "make" "test-go")))
#t)))))