summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 01cddf9d0c..cc503c5f0c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6123,27 +6123,21 @@ dereferencing accessor layer.")
(define-public python-jsonschema-specifications
(package
(name "python-jsonschema-specifications")
- (version "2023.12.1")
+ (version "2024.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jsonschema_specifications" version))
(sha256
- (base32 "1k348xkq45jx13kmv32ls6k4qvjq3ywd4q0i7zamw3z7nf3ng9s8"))))
+ (base32 "0wp2g90jsaa48g1v0n6m43ywhh9cj1ig19q25lay334m74vbhf0g"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-pyproject
- (lambda _
- ;; The build system does not like this.
- (substitute* "pyproject.toml"
- ((" \"Topic :: File Formats.*") "")))))))
- (propagated-inputs (list python-importlib-resources
- python-referencing-bootstrap))
(native-inputs
- (list python-hatchling python-hatch-vcs python-pytest))
+ (list python-hatch-vcs
+ python-hatchling
+ python-pytest))
+ (propagated-inputs
+ (list python-importlib-resources
+ python-referencing-bootstrap))
(home-page "https://github.com/python-jsonschema/jsonschema-specifications")
(synopsis
"JSON Schema meta-schemas and vocabularies, exposed as a Registry")