summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-plasma.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 58c085ca6a..244fe49f23 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -2909,7 +2909,15 @@ fetchinitialplayertest|mprisdeclarativetest|mediakeystest|shelltest|\
locationsrunnertest|testimagefinder|testimagelistmodel|\
testpackageimagelistmodel|testimageproxymodel|testslidemodel|testimagefrontend|\
dbusservicewatchertest|klippertest|keystatetest|lockedtest|tst_triangleFilter|\
-testimagebackend)")))))))
+testimagebackend)"))))
+ ;; share/dbus-1/system-services have same name file
+ ;; when dbus-root-service-type merge it, wail report
+ ;; "file exists".
+ (add-after 'install 'remove-dbus-service
+ (lambda _
+ (delete-file
+ (string-append
+ #$output "/share/dbus-1/services/org.kde.fontinst.service")))))))
(home-page "https://invent.kde.org/plasma/plasma-workspace")
(synopsis "Plasma workspace components")
(description