summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 25542c1e06..8aee673653 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2021 Mathieu Othacehe <[email protected]>
;;; Copyright © 2022 Kaelyn Takata <[email protected]>
;;; Copyright © 2022, 2024 dan <[email protected]>
-;;; Copyright © 2023 Zheng Junjie <[email protected]>
+;;; Copyright © 2023, 2024 Zheng Junjie <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -297,7 +297,11 @@ interpretation of the specifications for these languages.")
(search-input-directory
%build-inputs "include/vulkan"))))
#$@(if (%current-target-system)
- #~("-DBUILD_TESTS=OFF" "-DUSE_GAS=OFF")
+ #~("-DBUILD_TESTS=OFF" "-DUSE_GAS=OFF"
+ (string-append "-DPKG_CONFIG_EXECUTABLE="
+ (search-input-file
+ %build-inputs
+ (string-append "bin/" #$(pkg-config-for-target)))))
#~("-DBUILD_TESTS=ON")))
#:phases
#~(modify-phases %standard-phases