summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index bcafd154e7..29e0ee5951 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <[email protected]>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <[email protected]>
-;;; Copyright © 2015, 2016, 2017 Leo Famulari <[email protected]>
+;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <[email protected]>
;;; Copyright © 2016, 2017 Marius Bakke <[email protected]>
;;; Copyright © 2017 Ben Sturmfels <[email protected]>
;;; Copyright © 2016 Sou Bunnbu <[email protected]>
@@ -996,3 +996,23 @@ relevant RFCs too.")
(define-public python2-service-identity
(package-with-python2 python-service-identity))
+
+(define-public python-hkdf
+ (package
+ (name "python-hkdf")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hkdf" version))
+ (sha256
+ (base32
+ "1jhxk5vhxmxxjp3zj526ry521v9inzzl8jqaaf0ma65w6k332ak2"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/casebeer/python-hkdf")
+ (synopsis "HMAC-based Extract-and-Expand Key Derivation Function (HKDF)")
+ (description "This package provides a Python implementation of the HMAC Key
+Derivation function (HKDF) defined in RFC 5869.")
+ (license license:bsd-2)))