summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index aac500f443..f5f615f03f 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -438,6 +438,35 @@ nosetests, etc...) in Python projects.")
@command{behave}.")
(license license:expat)))
+(define-public python-doc8
+ (package
+ (name "python-doc8")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "doc8" version))
+ (sha256
+ (base32 "162b6lff5pcd4sp6sfm5fds8kllnx7ipzbyvi3irgk718h0z698j"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-docutils
+ python-pygments
+ python-restructuredtext-lint
+ python-stevedore
+ python-tomli))
+ (home-page "https://launchpad.net/doc8")
+ (synopsis "Style checker for Sphinx (or other) RST documentation")
+ (description
+ "Doc8 is an opinionated style checker for reStructured Text and plain
+text styles of documentation.")
+ (license license:asl2.0)))
+
(define-public python-eradicate
(package
(name "python-eradicate")