summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index f7184bd49a..b580f8b2a7 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <[email protected]>
+;;; Copyright © 2014, 2022 Ludovic Courtès <[email protected]>
;;; Copyright © 2016 Daniel Pimentel <[email protected]>
;;; Copyright © 2016 Leo Famulari <[email protected]>
;;; Copyright © 2017, 2018, 2019, 2022 Ricardo Wurmus <[email protected]>
@@ -406,6 +406,12 @@ from protobuf specification files.")
(base32
"1ja2vpk9nklllmsirmil2s4l7ni9yfqvbvj47zz5xx17s1k1bhxd"))))
(build-system python-build-system)
+ (inputs (list protobuf))
+ (arguments
+ `(;; Favor C++ implementation from protobuf over the native Python
+ ;; implementation. The additional dependency yields significant
+ ;; performance improvements for some workloads.
+ #:configure-flags '("--cpp_implementation")))
(home-page "https://github.com/google/protobuf")
(synopsis "Protocol buffers is a data interchange format")
(description
@@ -462,9 +468,8 @@ structured data.")
(sha256
(base32
"04bqb12smlckzmgkj6vgmpbr3cby0n6726cmz33bqr7kn1vb728l"))))
- (inputs
- (cons python-six
- (package-inputs python-protobuf)))))
+ (arguments '()) ;no "--cpp_implementation" here
+ (inputs (list python-six))))
(define-public python-proto-plus
(package