summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tvm_fix_cpptest_build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/tvm_fix_cpptest_build.patch')
-rw-r--r--gnu/packages/patches/tvm_fix_cpptest_build.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/tvm_fix_cpptest_build.patch b/gnu/packages/patches/tvm_fix_cpptest_build.patch
new file mode 100644
index 0000000000..7c3efac549
--- /dev/null
+++ b/gnu/packages/patches/tvm_fix_cpptest_build.patch
@@ -0,0 +1,18 @@
+Fix build of cpptest by correcting relative include paths
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 757b0d1a8..546ecd516 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -778,6 +778,11 @@ endif()
+ if(GTEST_FOUND)
+ tvm_file_glob(GLOB_RECURSE TEST_SRCS tests/cpp/*.cc)
+ add_executable(cpptest ${TEST_SRCS})
++
++ # fix building cpptest if we don't use 3rdParty subtree as when building with GNU Guix
++ # allowng relative paths starting with ../../.. to point to the top of the source dir
++ target_include_directories(cpptest PRIVATE tests/cpp/runtime)
++
+ # include runtime files for unit testing
+ target_link_libraries(cpptest PRIVATE ${TVM_TEST_LIBRARY_NAME} GTest::GTest GTest::Main GTest::gmock pthread dl)
+ if(DEFINED LLVM_LIBS)