summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-102-makeicecat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-102-makeicecat.patch')
-rw-r--r--gnu/packages/patches/icecat-102-makeicecat.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-102-makeicecat.patch b/gnu/packages/patches/icecat-102-makeicecat.patch
new file mode 100644
index 0000000000..940ca36b6c
--- /dev/null
+++ b/gnu/packages/patches/icecat-102-makeicecat.patch
@@ -0,0 +1,51 @@
+Make some of the changes needed to the 'makeicecat' script, to allow it to run
+in a snippet without network access. After this patch is applied, some
+additional changes will be made using 'substitute*'.
+
+diff --git a/makeicecat b/makeicecat
+index bf2b7a6..bc3b19b 100755
+--- a/makeicecat
++++ b/makeicecat
+@@ -56,7 +56,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
+ # debug/shell options
+ readonly DEVEL=0
+ set -euo pipefail
+-(( DEVEL )) && set -x
++set -x
+
+
+ ###############################################################################
+@@ -455,7 +455,7 @@ configure_search()
+
+
+ # Process various JSON pre-configuration dumps.
+- python3 ../../tools/process-json-files.py . browser/components/extensions/schemas/
++ python3 "${DATADIR}"/../tools/process-json-files.py . browser/components/extensions/schemas/
+ }
+
+ configure_mobile()
+@@ -837,12 +837,12 @@ finalize_sourceball()
+ # entry point
+ ###############################################################################
+
+-validate_env || exit 1
+-prepare_env
+-fetch_source
+-verify_sources
+-extract_sources
+-fetch_l10n
++# validate_env || exit 1
++# prepare_env
++# fetch_source
++# verify_sources
++# extract_sources
++# fetch_l10n
+ apply_patches
+ configure
+ configure_search
+@@ -854,4 +854,4 @@ prepare_macos_packaging
+ configure_extensions
+ configure_onboarding
+ apply_bugfixes
+-finalize_sourceball
++# finalize_sourceball