summaryrefslogtreecommitdiff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm70
1 files changed, 70 insertions, 0 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 12892db137..5b83b96801 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Ryan Prior <[email protected]>
;;; Copyright © 2023 Wamm K. D. <[email protected]>
+;;; Copyright © 2023 altadil <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,11 +27,13 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages package-management)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages xml)
#:use-module (gnu packages web)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages)
#:use-module (guix build-system meson)
#:use-module (guix git-download)
@@ -72,6 +75,22 @@ things, it provides complex widgets and convenience functions designed for use
in apps built for the Pantheon desktop.")
(license license:lgpl3+)))
+;; This is required for pantheon apps that have not been ported to GTK4 yet.
+(define-public granite-6
+ (package
+ (inherit granite)
+ (version "6.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/granite")
+ (commit version)))
+ (file-name (git-file-name "granite" version))
+ (sha256
+ (base32
+ "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
+ (propagated-inputs (list glib libgee gtk+))))
+
(define-public pantheon-calculator
(package
(name "pantheon-calculator")
@@ -113,6 +132,57 @@ arithmetic. It is the default calculator application in the Pantheon
desktop.")
(license license:gpl3)))
+(define-public pantheon-terminal
+ (package
+ (name "pantheon-terminal")
+ (version "6.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/terminal")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x3gzghnfx4a1q2zhra4dysc0pm1zvlfdxj96qhfb627pz16iv4k"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:tests? #f ; Tests invole launching the terminal.
+ #:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'set-environment-variables
+ (lambda _
+ ;; Disable compiling schemas and updating desktop databases
+ (setenv "DESTDIR" "/")))
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.terminal"))
+ (link (string-append out "/bin/pantheon-terminal")))
+ (symlink bin link)))))))
+ (native-inputs (list appstream
+ desktop-file-utils ;required for tests
+ gettext-minimal ;for msgfmt
+ `(,glib "bin") ;for glib-compile-resources
+ gobject-introspection
+ pkg-config
+ vala
+ xvfb-run))
+ (inputs (list granite-6
+ gtk+
+ libgee
+ libhandy
+ pcre2
+ vte))
+ (synopsis "Terminal emulator from elementaryOS")
+ (description "pantheon-terminal is a lightweight, beautiful and simple
+terminal. It comes with sane defaults, browser-class tabs, sudo paste
+protection, smart copy/paste, and little to no configuration. It is the default
+terminal in the Pantheon desktop.")
+ (home-page "https://elementary.io/open-source")
+ (license license:lgpl3)))
+
(define-public sideload
(package
(name "sideload")