summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7984e40382..d820b855d8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 David Hashe <[email protected]>
;;; Copyright © 2016 Eric Bavier <[email protected]>
;;; Copyright © 2016 Jan Nieuwenhuizen <[email protected]>
-;;; Copyright © 2016, 2018 Efraim Flashner <[email protected]>
+;;; Copyright © 2016, 2018, 2019 Efraim Flashner <[email protected]>
;;; Copyright © 2016-2018 Julien Lepiller <[email protected]>
;;; Copyright © 2017 Ben Woodcroft <[email protected]>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
@@ -1115,6 +1115,7 @@ files in these formats.")
(uri (git-reference
(url "https://github.com/ocaml/Zarith")
(commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
"0hv5ywz1q2cgn8apfz490clwk5hcynr937g2v8i13x2ax4bnv0lz"))))
@@ -2645,6 +2646,7 @@ big- and little-endian, with their unsafe counter-parts.")
(uri (git-reference
(url "https://github.com/mirage/ocaml-cstruct")
(commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
"0m4bz0digcsc8l2msfikwcbi1y371kccx6xnkwrz212mf5mp98bv"))))
@@ -3043,7 +3045,9 @@ library is currently designed for Unicode Standard 3.2.")
(version "1.1.0")
(source (origin
(method url-fetch)
- (uri "https://bitbucket.org/zandoye/charinfo_width/get/1.1.0.tar.gz")
+ (uri (string-append "https://bitbucket.org/zandoye/charinfo_width"
+ "/get/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"00bv4p1yqs8y0z4z07wd9w9yyv669dikp9b04dcjbwpiy2wy0086"))))