summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 85afc8cefc..f1e4414bac 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <[email protected]>
-;;; Copyright © 2014-2023 Ludovic Courtès <[email protected]>
+;;; Copyright © 2014-2024 Ludovic Courtès <[email protected]>
;;; Copyright © 2014 Ian Denhardt <[email protected]>
;;; Copyright © 2016 Andreas Enge <[email protected]>
;;; Copyright © 2017 Dave Love <[email protected]>
@@ -78,7 +78,9 @@
"doc" ;400+ section 3 man pages
"debug"))
(inputs
- (append (list libx11 cairo ncurses expat)
+ (append (if (%current-target-system)
+ '() ;fewer dependencies when cross-compiling
+ (list libx11 cairo ncurses expat))
(if (target-arm32?) '() (list numactl))))
(propagated-inputs
;; hwloc.pc lists it in 'Requires.private'.