summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 0011faa50f..8348638614 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -16,11 +16,11 @@
;;; Copyright © 2019 Brett Gilio <[email protected]>
;;; Copyright © 2020 Giacomo Leidi <[email protected]>
;;; Copyright © 2020 Jakub Kądziołka <[email protected]>
-;;; Copyright © 2021 Maxime Devos <[email protected]>
+;;; Copyright © 2021, 2022 Maxime Devos <[email protected]>
;;; Copyright © 2020, 2021 Maxim Cournoyer <[email protected]>
;;; Copyright © 2021 Julien Lepiller <[email protected]>
;;; Copyright © 2021 Lars-Dominik Braun <[email protected]>
-;;; Copyright © 2021 Guillaume Le Vaillant <[email protected]>
+;;; Copyright © 2021, 2022 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2021 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022 Greg Hogan <[email protected]>
;;;
@@ -945,8 +945,16 @@ of programming tools as well as libraries with equivalent functionality.")
(arguments
(substitute-keyword-arguments (package-arguments llvm)
((#:phases phases)
- `(modify-phases ,phases
- (delete 'install-opt-viewer)))))))
+ #~(modify-phases #$phases
+ (add-before 'build 'shared-lib-workaround
+ ;; Even with CMAKE_SKIP_BUILD_RPATH=FALSE, llvm-tblgen
+ ;; doesn't seem to get the correct rpath to be able to run
+ ;; from the build directory. Set LD_LIBRARY_PATH as a
+ ;; workaround.
+ (lambda _
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (getcwd) "/lib"))))
+ (delete 'install-opt-viewer)))))))
(define-public clang-runtime-3.9.1
(clang-runtime-from-llvm