summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 644780b5e9..b8a8af9280 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2017 Ludovic Courtès <[email protected]>
;;; Copyright © 2014 Ian Denhardt <[email protected]>
;;; Copyright © 2015, 2016 Alex Kost <[email protected]>
-;;; Copyright © 2016 Efraim Flashner <[email protected]>
+;;; Copyright © 2016, 2017 Efraim Flashner <[email protected]>
;;; Copyright © 2017 Alex Griffin <[email protected]>
;;; Copyright © 2017 ng0 <[email protected]>
;;; Copyright © 2017 Mathieu Othacehe <[email protected]>
@@ -214,7 +214,13 @@ it and customize it for your needs.")
(modify-phases %standard-phases
(add-after 'unpack 'autogen
(lambda _
- (zero? (system* "sh" "autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh"))))
+ (add-before 'install 'skip-gtk-update-icon-cache
+ (lambda _
+ ;; Don't create 'icon-theme.cache'
+ (substitute* (find-files "data" "^Makefile$")
+ (("gtk-update-icon-cache") (which "true")))
+ #t)))))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)