summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm56
1 files changed, 55 insertions, 1 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 42e2a15709..7e1935ece3 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2017, 2018, 2019 Ricardo Wurmus <[email protected]>
;;; Copyright © 2016 Nikita <[email protected]>
;;; Copyright © 2017 rsiddharth <[email protected]>
-;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2017, 2019, 2023 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2020 Giacomo Leidi <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -290,6 +290,37 @@ public key algorithms, key derivation numbers, cryptographic random number
generators, and more.")
(license license:bsd-3)))
+(define-public ghc-curve25519
+ (package
+ (name "ghc-curve25519")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "curve25519" version))
+ (sha256
+ (base32 "1p8b1lppkvc19974hr43lcqdi4nj55j2nf7gsnp8dn7gyf23aayq"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ (list ghc-hunit
+ ghc-quickcheck
+ ghc-tagged
+ ghc-test-framework
+ ghc-test-framework-hunit
+ ghc-test-framework-quickcheck2))
+ (inputs
+ (list ghc-crypto-api))
+ (properties '((upstream-name . "curve25519")))
+ (home-page "https://github.com/acw/curve25519")
+ (synopsis "Fast implementations of the curve25519 elliptic curve primitives.")
+ (description
+ "This module provides Haskell bindings and extensions to the curve25519-donna
+codebase. It's a pretty straightforward implementation of the basic
+cryptographic routines you'd want from a project that uses curve25519: key
+generation, and key agreement. For further functionality, you'll want to look
+elsewhere.")
+ (license license:bsd-3)))
+
(define-public ghc-digest
(package
(name "ghc-digest")
@@ -716,6 +747,29 @@ stable. You may also be interested in the tls package,
implementation of SSL.")
(license license:public-domain)))
+(define-public ghc-hsopenssl-x509-system
+ (package
+ (name "ghc-hsopenssl-x509-system")
+ (version "0.1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "HsOpenSSL-x509-system" version))
+ (sha256
+ (base32 "15mp70bqg1lzp971bzp6wym3bwzvxb76hzbgckygbfa722xyymhr"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-hsopenssl))
+ (properties '((upstream-name . "HsOpenSSL-x509-system")))
+ (home-page "https://github.com/redneb/HsOpenSSL-x509-system")
+ (synopsis "Use the system's native CA certificate store with HsOpenSSL")
+ (description
+ "This package provides a cross-platform library that tries to find
+a (reasonable) CA certificate bundle that can be used with HsOpenSSL to verify
+the certificates of remote peers. It is for HsOpenSSL what x509-system is for
+the tls package, and borrows some ideas from x509-system.")
+ (license license:bsd-3)))
+
(define-public ghc-openssl-streams
(package
(name "ghc-openssl-streams")