summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e4b6a09f2d..ee63a78cf7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,8 +1,10 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018, 2019 Leo Famulari <[email protected]>
+;;; Copyright © 2018 Pierre-Antoine Rouby <[email protected]>
;;; Copyright © 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2022 Dominic Martinez <[email protected]>
;;; Copyright © 2023 Benjamin <[email protected]>
+;;; Copyright © 2023 Katherine Cox-Buday <[email protected]>
;;; Copyright © 2023 Sharlatan Hellseher <[email protected]>
;;; Copyright © 2023 Thomas Ieong <[email protected]>
;;; Copyright © 2024 Artyom V. Poptsov <[email protected]>
@@ -87,6 +89,29 @@ optimized for sparse nodes of
@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
(license license:expat)))
+(define-public go-github-com-burntsushi-toml
+ (package
+ (name "go-github-com-burntsushi-toml")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BurntSushi/toml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1v9czq4hsyvdz7yx70y6sgq77wmrgfmn09r9cj4w85z38jqnamv7"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/BurntSushi/toml"))
+ (home-page "https://github.com/BurntSushi/toml")
+ (synopsis "Toml parser and encoder for Go")
+ (description
+ "This package is toml parser and encoder for Go. The interface is
+similar to Go's standard library @code{json} and @code{xml} package.")
+ (license license:expat)))
+
(define-public go-github-com-cyberdelia-go-metrics-graphite
(package
(name "go-github-com-cyberdelia-go-metrics-graphite")