summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0aeabccefa..177ab8a20f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6932,6 +6932,33 @@ well as a program to generate applications and command files.")
slices, JSON and other data.")
(license license:expat)))
+(define-public go-github-com-subosito-gotenv
+ (package
+ (name "go-github-com-subosito-gotenv")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/subosito/gotenv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h7kb9mc67rl16kvls2d16pimdrz59l5x4l002qsv2p2766mpjif"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/subosito/gotenv"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-text))
+ (home-page "https://github.com/subosito/gotenv")
+ (synopsis "Go library for loading environment variables from files")
+ (description
+ "Go library for loading environment variables from files")
+ (license license:expat)))
+
(define-public go-github-com-syndtr-goleveldb
(package
(name "go-github-com-syndtr-goleveldb")