summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d357584469..5f0dbf2bc4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <[email protected]>
;;; Copyright © 2022 Dominic Martinez <[email protected]>
;;; Copyright © 2023 Benjamin <[email protected]>
+;;; Copyright © 2023 Fries <[email protected]>
;;; Copyright © 2023 Hilton Chain <[email protected]>
;;; Copyright © 2023 Katherine Cox-Buday <[email protected]>
;;; Copyright © 2023 Nicolas Graves <[email protected]>
@@ -607,6 +608,33 @@ similar to Go's standard library @code{json} and @code{xml} package.")
"This package is a Go library that draws progress bars on the terminal.")
(license license:bsd-3)))
+(define-public go-github-com-chzyer-logex
+ (package
+ (name "go-github-com-chzyer-logex")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chzyer/logex")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0c9yr3r7dl3lcs22cvmh9iknihi9568wzmdywmc2irkjdrn8bpxw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; See <https://github.com/chzyer/logex/issues/4> and
+ ;; <https://github.com/chzyer/logex/pull/7>.
+ #:tests? #f
+ #:import-path "github.com/chzyer/logex"))
+ (home-page "https://github.com/chzyer/logex")
+ (synopsis "Golang log library")
+ (description
+ "This package provides a Golang log library supporting tracing and log
+levels that works by wrapping the standard @code{log} library.")
+ (license license:expat)))
+
(define-public go-github-com-coocood-freecache
(package
(name "go-github-com-coocood-freecache")