summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index fbad61e269..d2ee54f021 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2019 Brian Leung <[email protected]>
;;; Copyright © 2019, 2020 Leo Famulari <[email protected]>
;;; Copyright © 2020 Danny Milosavljevic <[email protected]>
-;;; Copyright © 2020 Efraim Flashner <[email protected]>
+;;; Copyright © 2020, 2024 Efraim Flashner <[email protected]>
;;; Copyright © 2020 HiPhish <[email protected]>
;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2020 Ryan Prior <[email protected]>
@@ -80,6 +80,10 @@
(replace 'check
(lambda* (#:key tests? import-path #:allow-other-keys)
(when tests?
+ ;; We need to extend the timeout on some architectures.
+ ;; 64 is the default in extra_test.go.
+ (setenv "GOLDMARK_TEST_TIMEOUT_MULTIPLIER"
+ (number->string (* 64 5)))
(with-directory-excursion (string-append "src/" import-path)
(invoke "go" "test" "-v" "./..."))))))))
(home-page "https://github.com/yuin/goldmark/")