summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2c864c9287..82a468dfa1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -72,7 +72,7 @@
;;; Copyright © 2022 Roman Riabenko <[email protected]>
;;; Copyright © 2022, 2023 zamfofex <[email protected]>
;;; Copyright © 2022 Gabriel Arazas <[email protected]>
-;;; Copyright © 2022, 2024 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2022-2024 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022 Hendursaga <[email protected]>
;;; Copyright © 2022 Parnikkapore <[email protected]>
;;; Copyright © 2023 Zheng Junjie <[email protected]>
@@ -10884,8 +10884,7 @@ kingdom.")
(snippet
'(begin
;; Octocat seems to be non-free. Oddly, Debian doesn't strip it.
- (delete-file-recursively "data/ball/octocat")
- #t))))
+ (delete-file-recursively "data/ball/octocat")))))
(build-system copy-build-system)
(arguments
`(#:install-plan
@@ -10950,20 +10949,19 @@ kingdom.")
(string-append "LOCALEDIR=" out "/share/locale")
(string-append "SDL_CPPFLAGS=-I"
sdl
- "/include/SDL2/")))
- #t))
+ "/include/SDL2/")))))
(add-after 'install 'fix-some-broken-fonts
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/neverball")
`("LANG" = ("en_US.utf8")))
(wrap-program (string-append out "/bin/neverputt")
- `("LANG" = ("en_US.utf8"))))
- #t)))))
+ `("LANG" = ("en_US.utf8")))))))))
(native-inputs
`(("gettext" ,gettext-minimal))) ;for msgfmt
(inputs
- `(("libjpeg" ,libjpeg-turbo)
+ `(("bash-minimal" ,bash-minimal)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libvorbis" ,libvorbis)
("physfs" ,physfs)