summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 47ba393c47..4bbfdb81ed 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -33,7 +33,7 @@
;;; Copyright © 2022 Malte Frank Gerdes <[email protected]>
;;; Copyright © 2022 Konstantinos Agiannis <[email protected]>
;;; Copyright © 2022 Greg Hogan <[email protected]>
-;;; Copyright © 2022, 2024 Artyom V. Poptsov <[email protected]>
+;;; Copyright © 2022, 2024, 2025 Artyom V. Poptsov <[email protected]>
;;; Copyright © 2022 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022, 2023, 2025 Felix Gruber <[email protected]>
;;; Copyright © 2023 Theofilos Pechlivanis <[email protected]>
@@ -175,6 +175,33 @@
#:use-module (gnu packages xorg)
#:use-module ((srfi srfi-1) #:hide (zip)))
+(define-public cutecom
+ (package
+ (name "cutecom")
+ (version "0.60.0-RC1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/cutecom/cutecom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k67x4l27ac6sb944b42zscm0ffq2fxbghapspgj75g4dr8ip38a"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ;no tests
+ (inputs
+ (list qtbase qttools qtserialport))
+ (home-page "https://gitlab.com/cutecom/cutecom")
+ (synopsis "Graphical serial terminal")
+ (description
+ "@code{cutecom} is a graphical serial terminal, like @code{minicom}. It is
+aimed mainly at hardware developers or other people who need a terminal to talk to
+their devices.")
+ (license license:gpl3)))
+
(define-public librecad
(package
(name "librecad")