summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 1da4141519..bee65663b6 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -746,16 +746,17 @@ with a layered architecture of JTAG interface and TAP support.")
"0w0dff3s7wv2d9m78a4jhckiik58q38wx6wpbba5hzbs4yxz35ck"))
(patches '())))
(arguments
- `(;; FIXME: For some reason there are many test failures. It's not
- ;; obvious how to fix the failures.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _ (chdir "binutils") #t)))
- ,@(substitute-keyword-arguments (package-arguments xbinutils)
- ((#:configure-flags flags)
- `(cons "--disable-werror" ,flags)))))
+ (list
+ ;; FIXME: For some reason there are many test failures. It's not
+ ;; obvious how to fix the failures.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "binutils") #t))
+ #$@(substitute-keyword-arguments (package-arguments xbinutils)
+ ((#:configure-flags flags)
+ #~(cons "--disable-werror" #$flags))))))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)