summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8f23e1856f..ca87a2ed46 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -78,7 +78,7 @@
;;; Copyright © 2020 Eric Bavier <[email protected]>
;;; Copyright © 2020, 2021 Morgan Smith <[email protected]>
;;; Copyright © 2020 Peng Mei Yu <[email protected]>
-;;; Copyright © 2020 Niklas Eklund <[email protected]>
+;;; Copyright © 2020, 2021 Niklas Eklund <[email protected]>
;;; Copyright © 2020 Marco Grassi <[email protected]>
;;; Copyright © 2020 Tomás Ortín Fernández <[email protected]>
;;; Copyright © 2020 Zhu Zihao <[email protected]>
@@ -5576,6 +5576,31 @@ errors.")
the current Cargo project.")
(license license:gpl3+)))
+(define-public emacs-flycheck-package
+ (package
+ (name "emacs-flycheck-package")
+ (version "0.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/flycheck-package")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00py39n1383761wq6wp194pvyk94ydqdbxj9kl64g9jnipkp7849"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-package-lint" ,emacs-package-lint)))
+ (home-page "https://github.com/purcell/flycheck-package")
+ (synopsis "Flycheck checker for elisp package metadata")
+ (description
+ "This library provides a flycheck checker for the metadata in Emacs Lisp
+files which are intended to be packages.")
+ (license license:gpl3+)))
+
(define-public emacs-elisp-demos
(package
(name "emacs-elisp-demos")