summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 62a1923571..e530d1d2a8 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2019 Jan Wielkiewicz <[email protected]>
;;; Copyright © 2020, 2021 Nicolò Balzarotti <[email protected]>
;;; Copyright © 2020 Roel Janssen <[email protected]>
-;;; Copyright © 2020, 2021, 2023 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2020, 2021, 2023, 2024 Ricardo Wurmus <[email protected]>
;;; Copyright © 2020 Brice Waegeneire <[email protected]>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <[email protected]>
;;; Copyright © 2020, 2022 Marius Bakke <[email protected]>
@@ -29,7 +29,7 @@
;;; Copyright © 2022 muradm <[email protected]>
;;; Copyright © 2022 Attila Lendvai <[email protected]>
;;; Copyright © 2022 Arun Isaac <[email protected]>
-;;; Copyright © 2022, 2023 David Elsing <[email protected]>
+;;; Copyright © 2022, 2023, 2024 David Elsing <[email protected]>
;;; Copyright © 2022, 2023 Zheng Junjie <[email protected]>
;;; Copyright © 2022, 2023, 2024 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022 Antero Mejr <[email protected]>
@@ -513,7 +513,17 @@ operating on batches.")
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DHWY_SYSTEM_GTEST=on"
- "-DBUILD_SHARED_LIBS=ON")))
+ "-DBUILD_SHARED_LIBS=ON")
+ ,@(if (string-prefix? "i686-linux" (or (%current-system)
+ (%current-target-system)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'really-skip-precision-tests
+ (lambda _
+ (substitute* "hwy/contrib/math/math_test.cc"
+ (("Skipping math_test due to GCC issue with excess precision.*" m)
+ (string-append m "return;\n")))))))
+ '())))
(native-inputs
(list googletest))
(home-page "https://github.com/google/highway")
@@ -2442,7 +2452,7 @@ CRC32C algorithm, which is specified in RFC 3720, section 12.1.")
(define-public fast-float
(package
(name "fast-float")
- (version "3.5.1")
+ (version "6.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2451,7 +2461,7 @@ CRC32C algorithm, which is specified in RFC 3720, section 12.1.")
(file-name (git-file-name name version))
(sha256
(base32
- "0z3rxxd0pwvw70dbnv63rm67biw829vdqf50y16isxm6g3sbrz8g"))))
+ "1xf4gbllha760cr0ri53zsja46dypj45lj070ijb5f78xavfd8f8"))))
(build-system cmake-build-system)
(arguments
(list
@@ -2467,9 +2477,7 @@ CRC32C algorithm, which is specified in RFC 3720, section 12.1.")
(("if\\(NOT supplemental_test_files_POPULATED.*")
(string-append
"set(supplemental_test_files_BINARY_DIR "
- (search-input-directory (or native-inputs inputs)
- "data")
- ")\nif(0)\n"))))))))
+ #$fast-float-test-files ")\nif(0)\n"))))))))
(native-inputs (list doctest fast-float-test-files))
(home-page "https://github.com/fastfloat/fast_float")
(synopsis "Floating point number parser for C++")