summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 32 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ccee9d1f60..cb0bdf766e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6687,7 +6687,7 @@ performance.")
(define-public htscodecs
(package
(name "htscodecs")
- (version "1.5.0")
+ (version "1.5.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/samtools/htscodecs/"
@@ -6695,7 +6695,7 @@ performance.")
version "/htscodecs-" version ".tar.gz"))
(sha256
(base32
- "1cys6hp438m1rfmgq6xig3q0md7nh0m03jb17mc798q13lsggpil"))))
+ "0nykdf08wil6iiihgf5qlb04n70yv4zqqj7c27vpnpwpr2r2ns62"))))
(build-system gnu-build-system)
(inputs (list bzip2 zlib))
(home-page "https://github.com/samtools/htscodecs")
@@ -6721,7 +6721,11 @@ name/ID compression and quality score compression derived from fqzcomp.")
version "/htslib-" version ".tar.bz2"))
(sha256
(base32
- "093r1n4s134k50m9a925yn95gyi90ps5dlgc6gq4qwvkzxx7qsv0"))))
+ "093r1n4s134k50m9a925yn95gyi90ps5dlgc6gq4qwvkzxx7qsv0"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "htscodecs")))))
(build-system gnu-build-system)
;; Let htslib translate "gs://" and "s3://" to regular https links with
;; "--enable-gcs" and "--enable-s3". For these options to work, we also
@@ -6729,12 +6733,13 @@ name/ID compression and quality score compression derived from fqzcomp.")
(arguments
`(#:configure-flags '("--enable-gcs"
"--enable-libcurl"
- "--enable-s3")))
+ "--enable-s3"
+ "--with-external-htscodecs")))
(inputs
(list bzip2 curl openssl xz))
;; This is referred to in the pkg-config file as a required library.
(propagated-inputs
- (list zlib))
+ (list htscodecs zlib))
(native-inputs
(list perl))
(home-page "https://www.htslib.org")
@@ -6757,7 +6762,14 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
version "/htslib-" version ".tar.bz2"))
(sha256
(base32
- "0pwk8yhhvb85mi1d2qhwsb4samc3rmbcrq7b1s0jz0glaa7in8pd"))))))
+ "0pwk8yhhvb85mi1d2qhwsb4samc3rmbcrq7b1s0jz0glaa7in8pd"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments htslib)
+ ((#:configure-flags cf #~'())
+ #~(delete "--with-external-htscodecs" #$cf))))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs htslib)
+ (delete "htscodecs")))))
(define-public htslib-1.12
(package/inherit htslib
@@ -6769,7 +6781,14 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
version "/htslib-" version ".tar.bz2"))
(sha256
(base32
- "1jplnvizgr0fyyvvmkfmnsywrrpqhid3760vw15bllz98qdi9012"))))))
+ "1jplnvizgr0fyyvvmkfmnsywrrpqhid3760vw15bllz98qdi9012"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments htslib)
+ ((#:configure-flags cf #~'())
+ #~(delete "--with-external-htscodecs" #$cf))))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs htslib)
+ (delete "htscodecs")))))
(define-public htslib-1.10
(package/inherit htslib
@@ -11732,7 +11751,7 @@ replacement for strverscmp.")
(copy-recursively (assoc-ref inputs "tests") "/tmp/tests")
(with-directory-excursion "/tmp/tests"
(invoke "multiqc" "data" "--ignore" "data/modules")))))))))
- (propagated-inputs
+ (inputs
(list python-click
python-coloredlogs
python-future
@@ -16412,7 +16431,11 @@ genomic scores), long range contacts and the visualization of viewpoints.")
(lambda _
(substitute* "setup.py"
(("matplotlib ==3.1.1")
- "matplotlib >=3.1.1")))))))
+ "matplotlib >=3.1.1"))))
+ (add-after 'unpack 'remove-invalid-syntax
+ (lambda _
+ (substitute* "setup.py"
+ ((".\\*,") ",")))))))
(propagated-inputs
(list python-future
python-gffutils