summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 04af72bc95..b6384e66ed 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2447,6 +2447,30 @@ operations:
@end itemize")
(license license:asl2.0)))
+(define-public python-telomerecat
+ (package
+ (name "python-telomerecat")
+ (version "4.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "telomerecat" version))
+ (sha256
+ (base32 "16mfdqmp0j6g3h26h59334w9lqb4qihqrlzwvgznj0fiqs1rkxn2"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-click python-numpy python-pandas
+ python-parabam python-pysam))
+ (home-page "https://github.com/cancerit/telomerecat")
+ (synopsis "Telomere computational analysis tool")
+ (description "Telomerecat is a tool for estimating the average telomere
+length (TL) for a paired end, whole genome sequencing (WGS) sample.
+
+Telomerecat is adaptable, accurate and fast. The algorithm accounts for
+sequencing amplification artifacts, anneouploidy (common in cancer samples)
+and noise generated by WGS. For a high coverage WGS BAM file of around 100GB
+telomerecat can produce an estimate in ~1 hour.")
+ (license license:gpl3)))
+
(define-public python-bioframe
(package
(name "python-bioframe")