summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
Diffstat (limited to 'etc')
-rw-r--r--etc/git/gitconfig1
-rw-r--r--etc/news.scm13
-rwxr-xr-xetc/teams.scm16
3 files changed, 27 insertions, 3 deletions
diff --git a/etc/git/gitconfig b/etc/git/gitconfig
index 654a630b18..9c7827ced2 100644
--- a/etc/git/gitconfig
+++ b/etc/git/gitconfig
@@ -20,6 +20,7 @@
[b4]
attestation-check-dkim = off
attestation-policy = off
+ shazam-am-flags = --signoff --3way
linkmask = https://yhetil.org/guix/%s
linktrailermask = https://yhetil.org/guix/%s
midmask = https://yhetil.org/guix/%s
diff --git a/etc/news.scm b/etc/news.scm
index ffb483fea0..3e8c88499f 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -19,6 +19,7 @@
;; Copyright © 2021, 2023 Jonathan Brielmaier <[email protected]>
;; Copyright © 2022 Thiago Jung Bauermann <[email protected]>
;; Copyright © 2024 Oleg Pykhalov <[email protected]>
+;; Copyright © 2024 Wilko Meyer <[email protected]>
;;
;; Copying and distribution of this file, with or without modification, are
;; permitted in any medium without royalty provided the copyright notice and
@@ -27,6 +28,18 @@
(channel-news
(version 0)
+ (entry (commit "10a193596368443f441077525ebbddf787d91e4b")
+ (title
+ (en "Linux-libre 4.14 removed due to end of upstream support")
+ (de "Linux-libre 4.14 wurde entfernt"))
+ (body
+ (en "The linux-libre 4.14 kernel series has reached the end of
+ its life, and is no longer supported upstream. For this
+ reason, it has been removed from GNU Guix.")
+ (de "Die @code{linux-libre} 4.14-Versionsreihe hat ihr
+Supportende erreicht und wird nicht mehr unterstützt („end of life“). Daher ist die
+Versionsreihe aus GNU Guix entfernt worden.")))
+
(entry (commit "519e1e3eb88ec532fc83ebb742d9919269b57c87")
(title
(de "Neue Option @samp{--max-layers=N} für den Befehl @command{guix pack}")
diff --git a/etc/teams.scm b/etc/teams.scm
index 28b988725c..6dd98ecd87 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -299,10 +299,16 @@ asdf-build-system."
(define-team go
(team 'go
#:name "Go team"
- #:scope (list "gnu/packages/golang.scm"
+ #:scope (list "gnu/packages/configuration-management.scm"
"gnu/packages/golang-check.scm"
- "guix/build/go-build-system.scm"
+ "gnu/packages/golang-crypto.scm"
+ "gnu/packages/golang-web.scm"
+ "gnu/packages/golang-xyz.scm"
+ "gnu/packages/golang.scm"
+ "gnu/packages/syncthing.scm"
+ "gnu/packages/terraform.scm"
"guix/build-system/go.scm"
+ "guix/build/go-build-system.scm"
"guix/import/go.scm"
"guix/scripts/import/go.scm"
"tests/go.scm")))
@@ -592,7 +598,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Efraim Flashner"
- embedded bootstrap julia rust science)
+ embedded bootstrap julia rust)
(define-member (person "jgart"
@@ -706,6 +712,10 @@ GLib/GIO, GTK, GStreamer and Webkit."
gnome)
+(define-member (person "Wilko Meyer"
+ kernel)
+
(define (find-team name)
(or (hash-ref %teams (string->symbol name))