summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/llvm.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index e87b88c1e3..7aab2ae8c3 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017 Roel Janssen <[email protected]>
;;; Copyright © 2018–2022 Marius Bakke <[email protected]>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2018, 2021-2023 Efraim Flashner <[email protected]>
+;;; Copyright © 2018, 2021-2024 Efraim Flashner <[email protected]>
;;; Copyright © 2018 Tim Gesthuizen <[email protected]>
;;; Copyright © 2018 Pierre Neidhardt <[email protected]>
;;; Copyright © 2019 Rutger Helling <[email protected]>
@@ -376,6 +376,11 @@ until LLVM/Clang 14."
"add_subdirectory(${LLVM_THIRD_PARTY_DIR}/uni\
ttest third-party/unittest)\n" line))))))
'())
+ ;; The build daemon goes OOM on i686-linux on this phase.
+ ,@(if (and (version>=? version "15")
+ (target-x86-32?))
+ '((delete 'make-dynamic-linker-cache))
+ '())
;; Awkwardly, multiple phases added after the same phase,
;; e.g. unpack, get applied in the reverse order. In other
;; words, adding 'change-directory last means it occurs