summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/lisp.scm6
-rw-r--r--gnu/packages/patches/sbcl-fix-riscv-build.patch19
3 files changed, 25 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 453e3fb5c7..62066a30dc 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -20,7 +20,7 @@
# Copyright © 2018, 2019, 2020, 2021, 2022 Oleg Pykhalov <[email protected]>
# Copyright © 2018 Stefan Stefanović <[email protected]>
# Copyright © 2018, 2020, 2021, 2022, 2023 Maxim Cournoyer <[email protected]>
-# Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <[email protected]>
+# Copyright © 2019, 2020, 2021, 2022, 2044 Guillaume Le Vaillant <[email protected]>
# Copyright © 2019, 2020 John Soo <[email protected]>
# Copyright © 2019 Jonathan Brielmaier <[email protected]>
# Copyright © 2019 Evan Straw <[email protected]>
@@ -2004,6 +2004,7 @@ dist_patch_DATA = \
%D%/packages/patches/sbcl-clml-fix-types.patch \
%D%/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch \
%D%/packages/patches/sbcl-fix-ppc64-build.patch \
+ %D%/packages/patches/sbcl-fix-riscv-build.patch \
%D%/packages/patches/sbcl-png-fix-sbcl-compatibility.patch \
%D%/packages/patches/scalapack-gcc-10-compilation.patch \
%D%/packages/patches/scheme48-tests.patch \
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index aa7315a7ce..4f89779d8d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2018, 2019 Pierre Langlois <[email protected]>
;;; Copyright © 2019, 2020 Katherine Cox-Buday <[email protected]>
;;; Copyright © 2019 Jesse Gildersleve <[email protected]>
-;;; Copyright © 2019-2023 Guillaume Le Vaillant <[email protected]>
+;;; Copyright © 2019-2024 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2020 Marius Bakke <[email protected]>
;;; Copyright © 2020 Zhu Zihao <[email protected]>
;;; Copyright © 2021, 2023 Sharlatan Hellseher <[email protected]>
@@ -447,7 +447,9 @@ an interpreter, a compiler, a debugger, and much more.")
version "-source.tar.bz2"))
(sha256
(base32 "0xhpdnsg8idzxkn20iw8gd2rk470d7vc22vrp5clq9fj117vgn43"))
- (patches (search-patches "sbcl-fix-ppc64-build.patch"))
+ ;; TODO: Remove these patches when updating to sbcl > 2.4.0.
+ (patches (search-patches "sbcl-fix-ppc64-build.patch"
+ "sbcl-fix-riscv-build.patch"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/sbcl-fix-riscv-build.patch b/gnu/packages/patches/sbcl-fix-riscv-build.patch
new file mode 100644
index 0000000000..3e01ee6579
--- /dev/null
+++ b/gnu/packages/patches/sbcl-fix-riscv-build.patch
@@ -0,0 +1,19 @@
+commit b286d92af7468164c155c70d38213211b296fdfe
+Author: Douglas Katzman <[email protected]>
+Date: Wed Jan 10 11:46:55 2024 -0500
+
+ Fix riscv build
+
+diff --git a/src/compiler/riscv/float.lisp b/src/compiler/riscv/float.lisp
+index ce46d24ac..a16380293 100644
+--- a/src/compiler/riscv/float.lisp
++++ b/src/compiler/riscv/float.lisp
+@@ -578,7 +578,7 @@
+ (:results (res :scs (double-reg)))
+ (:arg-types signed-num)
+ (:result-types double-float)
+- (:translate make-double-float)
++ (:translate %make-double-float)
+ (:policy :fast-safe)
+ (:generator 2
+ (inst fmvx-> :double res bits)))