summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ad0881d441..4e8293ff0f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -147,7 +147,7 @@
;;; Copyright © 2024 Artyom V. Poptsov <[email protected]>
;;; Copyright © 2024 Spencer King <[email protected]>
;;; Copyright © 2024 emma thompson <[email protected]>
-;;; Copyright © 2024 Liam Hupfer <[email protected]>
+;;; Copyright © 2024-2025 Liam Hupfer <[email protected]>
;;; Copyright © 2024 aurtzy <[email protected]>
;;; Copyright © 2024 Olivier Rojon <[email protected]>
;;; Copyright © 2024 Divya Ranjan Pattanaik <[email protected]>
@@ -33691,6 +33691,29 @@ displays as you type thanks to Helm, though @command{notmuch-search} does the
real search.")
(license license:gpl3+)))
+(define-public emacs-notmuch-addr
+ (package
+ (name "emacs-notmuch-addr")
+ (version "1.1.0")
+ (home-page "https://github.com/tarsius/notmuch-addr")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "7dde87a44b6576eb736cb6a3b69df6b9946c5ecc")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xr78yw679swbl1bcwhk5k6qj1l9zr9nyl34ry2bpdryi370zkkp"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat emacs-notmuch))
+ (synopsis "Improved address completion for Notmuch")
+ (description
+ "A simple alternative to @code{notmuch-address}. It gives up on
+persistent caching, external scripts, and backward compatibility. It uses the
+improved completion API offered by Emacs 27.1 and later.")
+ (license license:gpl3+)))
+
(define-public emacs-notmuch-indicator
(package
(name "emacs-notmuch-indicator")