summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mail.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 1b69f32aa4..fca0ed9b78 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Paul van der Walt <[email protected]>
;;; Copyright © 2015, 2016, 2018 Eric Bavier <[email protected]>
;;; Copyright © 2015 Andreas Enge <[email protected]>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <[email protected]>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Christopher Allan Webber <[email protected]>
;;; Copyright © 2016 Al McElrath <[email protected]>
;;; Copyright © 2016 Leo Famulari <[email protected]>
@@ -1263,6 +1263,10 @@ which can add many functionalities to the base client.")
(install-file (string-append msmtpq "/msmtp-queue") bin)
(install-file (string-append msmtpq "/README.msmtpq") doc)
(install-file "scripts/vim/msmtp.vim" vimfiles)
+ ;; Don't rely on netcat being in the PATH to test for a
+ ;; connection, instead try tp ing debian.org.
+ (substitute* (string-append bin "/msmtpq")
+ (("EMAIL_CONN_TEST=n") "EMAIL_CONN_TEST=p"))
#t))))))
(synopsis
"Simple and easy to use SMTP client with decent sendmail compatibility")