summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/c.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 83268e871c..d89b6ea00d 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2018 Ludovic Courtès <[email protected]>
-;;; Copyright © 2016, 2017 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018 Pierre Neidhardt <[email protected]>
;;;
@@ -160,8 +160,7 @@ standard.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (zero? (system* "make" "-C" "cc/cpp" "test")))))))
+ (lambda _ (invoke "make" "-C" "cc/cpp" "test") #t)))))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)))