summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/mail.scm7
-rw-r--r--gnu/packages/patches/notmuch-emacs-test-output.patch89
3 files changed, 2 insertions, 95 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3d1afd4555..b8f3da7591 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1713,7 +1713,6 @@ dist_patch_DATA = \
%D%/packages/patches/network-manager-meson.patch \
%D%/packages/patches/nginx-socket-cloexec.patch \
%D%/packages/patches/nnpack-system-libraries.patch \
- %D%/packages/patches/notmuch-emacs-test-output.patch \
%D%/packages/patches/nsis-env-passthru.patch \
%D%/packages/patches/nss-getcwd-nonnull.patch \
%D%/packages/patches/nss-increase-test-timeout.patch \
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 4466e5e6d9..4fe3673a72 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1373,17 +1373,14 @@ invoking @command{notifymuch} from the post-new hook.")
(define-public notmuch
(package
(name "notmuch")
- (version "0.37")
+ (version "0.38.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://notmuchmail.org/releases/notmuch-"
version ".tar.xz"))
(sha256
- (base32 "1xl64xh0ijfkx265lcj9cqv1wkzha8gsn9jn4fw4xgvqigr6sxhf"))
- (patches
- ;; Output for some tests varies slightly in Emacs 29.
- (search-patches "notmuch-emacs-test-output.patch"))))
+ (base32 "0zll3s39s065pl9228xpklkjklllkyb3bf1szh0fw0rbfkjfp0jj"))))
(build-system gnu-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/notmuch-emacs-test-output.patch b/gnu/packages/patches/notmuch-emacs-test-output.patch
deleted file mode 100644
index 3c6d472d6b..0000000000
--- a/gnu/packages/patches/notmuch-emacs-test-output.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From e9e779ead4d703ad423e46c23abd0c9afd7d5ed2 Mon Sep 17 00:00:00 2001
-From: Arjan Adriaanse <[email protected]>
-Date: Tue, 15 Aug 2023 00:00:05 +0200
-Subject: [PATCH] test: fix expected output for Emacs 29
-
----
- test/T453-emacs-reply.sh | 1 -
- test/T454-emacs-dont-reply-names.sh | 9 +++------
- .../notmuch-reply-duplicate-4 | 1 -
- 3 files changed, 3 insertions(+), 8 deletions(-)
-
-diff --git a/test/T453-emacs-reply.sh b/test/T453-emacs-reply.sh
-index 0a27d066..de400b85 100755
---- a/test/T453-emacs-reply.sh
-+++ b/test/T453-emacs-reply.sh
-@@ -17,7 +17,6 @@ cat <<EOF > EXPECTED
- From: Notmuch Test Suite <[email protected]>
- To: Antoine Beaupré <[email protected]>
- Subject: Re: bug: "no top level messages" crash on Zen email loops
--In-Reply-To: <[email protected]>
- Fcc: MAIL_DIR/sent
- --text follows this line--
- Antoine Beaupré <[email protected]> writes:
-diff --git a/test/T454-emacs-dont-reply-names.sh b/test/T454-emacs-dont-reply-names.sh
-index 3a770177..9ed4f18b 100755
---- a/test/T454-emacs-dont-reply-names.sh
-+++ b/test/T454-emacs-dont-reply-names.sh
-@@ -17,13 +17,12 @@ test_emacs '(let ((message-dont-reply-to-names "notmuchmail\\|noreply\\|harvard"
- (test-visible-output "OUTPUT-FULL.raw"))'
-
- notmuch_dir_sanitize < OUTPUT-FULL.raw > OUTPUT-FULL
--head -6 OUTPUT-FULL > OUTPUT
-+head -5 OUTPUT-FULL > OUTPUT
-
- cat <<EOF > EXPECTED
- From: Notmuch Test Suite <[email protected]>
- To: Mikhail Gusarov <[email protected]>
- Subject: Re: [notmuch] Working with Maildir storage?
--In-Reply-To: <[email protected]>
- Fcc: MAIL_DIR/sent
- --text follows this line--
- EOF
-@@ -38,14 +37,13 @@ test_emacs '(let ((message-dont-reply-to-names
- (test-visible-output "OUTPUT-FULL-PRED.raw"))'
-
- notmuch_dir_sanitize < OUTPUT-FULL-PRED.raw > OUTPUT-FULL-PRED
--head -7 OUTPUT-FULL-PRED > OUTPUT-PRED
-+head -6 OUTPUT-FULL-PRED > OUTPUT-PRED
-
- cat <<EOF > EXPECTED-PRED
- From: Notmuch Test Suite <[email protected]>
- To: Lars Kellogg-Stedman <[email protected]>
- Subject: Re: [notmuch] Working with Maildir storage?
--In-Reply-To: <[email protected]>
- Fcc: MAIL_DIR/sent
- --text follows this line--
- EOF
-@@ -59,14 +57,13 @@ test_emacs '(let ((message-dont-reply-to-names nil))
- (test-visible-output "OUTPUT-FULL-NIL.raw"))'
-
- notmuch_dir_sanitize < OUTPUT-FULL-NIL.raw > OUTPUT-FULL-NIL
--head -7 OUTPUT-FULL-NIL > OUTPUT-NIL
-+head -6 OUTPUT-FULL-NIL > OUTPUT-NIL
-
- cat <<EOF > EXPECTED-NIL
- From: Notmuch Test Suite <[email protected]>
- To: Lars Kellogg-Stedman <[email protected]>, Mikhail Gusarov <[email protected]>
- Subject: Re: [notmuch] Working with Maildir storage?
--In-Reply-To: <[email protected]>
- Fcc: MAIL_DIR/sent
- --text follows this line--
- EOF
-diff --git a/test/emacs-reply.expected-output/notmuch-reply-duplicate-4 b/test/emacs-reply.expected-output/notmuch-reply-duplicate-4
-index 836f77b1..44b8c7a6 100644
---- a/test/emacs-reply.expected-output/notmuch-reply-duplicate-4
-+++ b/test/emacs-reply.expected-output/notmuch-reply-duplicate-4
-@@ -1,7 +1,6 @@
- From: Notmuch Test Suite <[email protected]>
- Subject: Re: [Pkg-emacsen-addons] Bug#916811: Increase severity to 'serious'
--In-Reply-To: <[email protected]>
- Fcc: MAIL_DIR/sent
- --text follows this line--
- Sean Whitton <[email protected]> writes:
---
-2.41.0
-