summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 82b002bd0d..9a31e3a087 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -257,6 +257,11 @@
(string-append (assoc-ref inputs "docbook-xml-4.1.2")
"/xml/dtd/docbook/"))))
#t))
+ (add-before 'check 'set-home
+ (lambda _
+ ;; A test using GIO expects ~/.config/glib-2.0/settings to be
+ ;; writable.
+ (setenv "HOME" (getcwd))))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))