summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/astronomy.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 874e9e07c4..30f99dea5f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4485,20 +4485,23 @@ astronomical images, especially when there is no WCS information available.")
(define-public python-skyfield
(package
(name "python-skyfield")
- (version "1.46")
+ (version "1.47")
(source
(origin
(method url-fetch)
(uri (pypi-uri "skyfield" version))
(sha256
- (base32 "1r4kpsh1pa4h3diyxy3gyapp0rykfjdqmn5w348a2ck2qkdlx997"))))
+ (base32 "0272pwk88csmrrl44fc4l52agd68pkg4zbmdhs7gliq5q9wf3hrs"))))
(build-system python-build-system)
(arguments
- ;; NOTE: (Sharlatan-20210207T163305+0000): tests depend on custom test
- ;; framework https://github.com/brandon-rhodes/assay
+ ;; XXX: Tests depend on custom test framework
+ ;; https://github.com/brandon-rhodes/assay
`(#:tests? #f))
- (inputs
- (list python-certifi python-jplephem python-numpy python-sgp4))
+ (propagated-inputs
+ (list python-certifi
+ python-jplephem
+ python-numpy
+ python-sgp4))
(home-page "https://rhodesmill.org/skyfield/")
(synopsis "Astronomy for Python")
(description