summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/version-control.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 438c25c366..b1417055b4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -47,7 +47,7 @@
;;; Copyright © 2022 Maxime Devos <[email protected]>
;;; Copyright © 2022 Dhruvin Gandhi <[email protected]>
;;; Copyright © 2015, 2022 David Thompson <[email protected]>
-;;; Copyright © 2023 Nicolas Graves <[email protected]>
+;;; Copyright © 2023, 2025 Nicolas Graves <[email protected]>
;;; Copyright © 2023 Bruno Victal <[email protected]>
;;; Copyright © 2023 Kjartan Oli Agustsson <[email protected]>
;;; Copyright © 2023 Steve George <[email protected]>
@@ -88,6 +88,7 @@
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
+ #:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system perl)
@@ -1919,6 +1920,18 @@ Features include:
@end itemize")
(license license:gpl2)))
+(define-public emacs-stgit
+ (package
+ (inherit stgit-2)
+ (name "emacs-stgit")
+ (build-system emacs-build-system)
+ (arguments
+ (list #:include '(list "contrib/stgit.el")))
+ (synopsis "Emacs major mode for StGit interaction")
+ (description "This package a interactive tool to interact with git
+branches using StGit.")
+ (license license:gpl3+)))
+
(define-public stgit
(package
(name "stgit")