summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/boost.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 6a08b0d6c7..b1ab8a4ec9 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <[email protected]>
;;; Copyright © 2015 Andreas Enge <[email protected]>
;;; Copyright © 2016 Eric Bavier <[email protected]>
-;;; Copyright © 2015, 2019 Ludovic Courtès <[email protected]>
+;;; Copyright © 2015, 2019, 2020 Ludovic Courtès <[email protected]>
;;; Copyright © 2017 Thomas Danckaert <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018 Arun Isaac <[email protected]>
@@ -40,6 +40,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
@@ -138,6 +139,15 @@
,(%current-target-system)))))
'())
+ ;; Change an #ifdef __MACH__ that really targets macOS.
+ ;; TODO: Inline this on the next rebuild cycle.
+ ,@(if (hurd-target?)
+ '((substitute* "boost/test/utils/timer.hpp"
+ (("defined\\(__MACH__\\)")
+ "(defined __MACH__ && !defined __GNU__)"))
+ #t)
+ '())
+
(invoke "./bootstrap.sh"
(string-append "--prefix=" out)
;; Auto-detection looks for ICU only in traditional