summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 9778d9a1c6..ec7b5c041b 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -126,11 +126,13 @@
(not (null? (package-native-inputs this-package))))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-lib-path
+ (add-after 'unpack 'fix-lib-and-libexec-path
(lambda _
- ;; Always install into /lib and not into /lib64.
(substitute* "kde-modules/KDEInstallDirsCommon.cmake"
- (("\"lib64\"") "\"lib\""))
+ ;; Always install into /lib and not into /lib64.
+ (("\"lib64\"") "\"lib\"")
+ ;; Install into /libexec and not into /lib/libexec.
+ (("LIBDIR \"libexec\"") "EXECROOTDIR \"libexec\""))
;; Determine the install path by the major version of Qt.
;; TODO: Base the following on values taken from Qt