summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm30
-rw-r--r--gnu/packages/golang.scm29
2 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9802c71916..d38a2613d3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2893,6 +2893,36 @@ Differentiation between text and binary files}.
@end itemize")
(license license:expat)))
+(define-public go-github-com-go-git-go-git-fixtures-v4
+ (package
+ (name "go-github-com-go-git-go-git-fixtures-v4")
+ (version "4.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-git/go-git-fixtures")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1d6qs2mzbhz95aflpjh6ijywvb4ys73jvk2v30mickax3gmm2vlw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; XXX: panic: runtime error: makeslice: cap out of range
+ #:tests? (target-64bit?)
+ #:import-path "github.com/go-git/go-git-fixtures/v4"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-go-git-go-billy
+ go-gopkg-in-check-v1))
+ (home-page "https://github.com/go-git/go-git-fixtures/")
+ (synopsis "Fixtures used by @code{go-git}")
+ (description
+ "This package provides fixtures used by @code{go-git}.")
+ (license license:asl2.0)))
+
(define-public go-github-com-go-kit-log
(package
(name "go-github-com-go-kit-log")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9fee521134..7df540ba41 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6225,35 +6225,6 @@ can manipulate a @file{ssh_config} file from a program.")
temporal directories.")
(license license:expat))))
-(define-public go-github-com-go-git-go-git-fixtures-v4
- (package
- (name "go-github-com-go-git-go-git-fixtures-v4")
- (version "4.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/go-git/go-git-fixtures")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1d6qs2mzbhz95aflpjh6ijywvb4ys73jvk2v30mickax3gmm2vlw"))))
- (build-system go-build-system)
- (arguments
- (list
- ;; XXX: panic: runtime error: makeslice: cap out of range
- #:tests? (target-64bit?)
- #:import-path "github.com/go-git/go-git-fixtures/v4"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (propagated-inputs
- (list go-github-com-go-git-go-billy
- go-gopkg-in-check-v1))
- (home-page "https://github.com/go-git/go-git-fixtures/")
- (synopsis "Fixtures used by @code{go-git}")
- (description "This package provides fixtures used by @code{go-git}.")
- (license license:asl2.0)))
-
(define-public go-github-com-pkg-diff
(package
(name "go-github-com-pkg-diff")