summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gettext.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index b9070ae818..426be35a25 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Eric Bavier <[email protected]>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Miguel <[email protected]>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,7 @@
#:use-module (guix build-system perl)
#:use-module (gnu packages docbook)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages libunistring)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -106,7 +108,11 @@
#t)))))
;; When tests fail, we want to know the details.
- #:make-flags '("VERBOSE=yes")))
+ #:make-flags '("VERBOSE=yes"
+ ,@(if (hurd-target?)
+ ;; Linking to libgettextlib.so makes test-raise fail
+ '("XFAIL_TESTS=test-raise")
+ '()))))
(home-page "https://www.gnu.org/software/gettext/")
(synopsis
"Tools and documentation for translation (used to build other packages)")