summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pretty-print.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 12ec1f7889..b247cf21e1 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016, 2019, 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Ricardo Wurmus <[email protected]>
;;; Copyright © 2017 Marius Bakke <[email protected]>
-;;; Copyright © 2017 Ludovic Courtès <[email protected]>
+;;; Copyright © 2017, 2020 Ludovic Courtès <[email protected]>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Meiyo Peng <[email protected]>
;;; Copyright © 2020 Paul Garlick <[email protected]>
@@ -230,6 +230,18 @@ to @code{IOStreams}.")
#:parallel-tests? #f ;There appear to be race conditions
#:phases
(modify-phases %standard-phases
+ ,@(if (%current-target-system)
+ ;; 'doc/Makefile.am' tries to run stuff even when
+ ;; cross-compiling. Explicitly skip it.
+ ;; XXX: Inline this on next rebuild cycle.
+ `((add-before 'build 'skip-doc-directory
+ (lambda _
+ (substitute* "Makefile"
+ (("^SUBDIRS = (.*) doc(.*)$" _ before after)
+ (string-append "SUBDIRS = " before
+ " " after "\n")))
+ #t)))
+ '())
(add-before 'check 'patch-test-files
(lambda _
;; Unpatch shebangs in test input so that source-highlight