summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 972e9d0395..274432d194 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5290,6 +5290,30 @@ are used. Fastmap avoids this memory leak issue by implementing the map using
data structures in C++.")
(license license:expat)))
+(define-public r-fastglm
+ (package
+ (name "r-fastglm")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastglm" version))
+ (sha256
+ (base32 "0283kgk81cxbii7ljmp1rzqg5mzkvf7cj7lflhhhkgj5ljqina2i"))))
+ (properties `((upstream-name . "fastglm")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bh r-bigmemory r-rcpp r-rcppeigen))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=fastglm")
+ (synopsis
+ "Fast and stable fitting of generalized linear models using 'RcppEigen'")
+ (description
+ "This package fits generalized linear models efficiently using @code{RcppEigen}'.
+The iteratively reweighted least squares implementation utilizes the
+step-halving approach of Marschner to help safeguard against convergence
+issues.")
+ (license license:gpl2+)))
+
(define-public r-fastghquad
(package
(name "r-fastghquad")