summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <[email protected]>2025-02-21 14:31:54 +0530
committerMaxim Cournoyer <[email protected]>2025-02-22 23:55:24 +0900
commitfcda199a1c25a6987a1dd42285882a9e0e4da26e (patch)
tree9eeaae2de8ccaf7084872886e9a3896122ef1539 /gnu
parentf302e6bc1a2d42ef3a2088b6c2e82a36ff03cd05 (diff)
gnu: Add asyncplusplus.
* gnu/packages/cpp.scm (asyncplusplus): New variable. Change-Id: I6ba1b983ce05a634937d0d972e670ce636df3b94
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cpp.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 07ec5dace8..a456bf3b51 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -197,6 +197,33 @@ allocator that makes it easy to generate complex code without a significant
development effort.")
(license license:zlib))))
+(define-public asyncplusplus
+ (package
+ (name "asyncplusplus")
+ (version "1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Amanieu/asyncplusplus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0iswbh7y46kn412c52af0n8bc4fplm3y94yh10n2lchispzar72j"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Fix install location of cmake files.
+ '(substitute* "CMakeLists.txt"
+ (("DESTINATION cmake")
+ "DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake")))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no tests
+ (home-page "https://github.com/Amanieu/asyncplusplus")
+ (synopsis "Concurrency framework for C++11")
+ (description "Async++ is a concurrency framework for C++11.")
+ (license license:expat)))
+
(define-public biblesync
(package
(name "biblesync")